MATLAB returns errors where there are none

Hi all

I am currently running a code that I have created in MATLAB using the EPANET-MATLAB Toolkit.
The code makes use of a for loop. The number of iterations is fairly large, at 3200—one iteration for each pipe in my Water Distribution Network.

The problem that I am having is that MATLAB returns an error on some iterations for no reason.
My first run returned an error on iteration 760. Without changing the code, I reran it and received the same error on iteration 1356. Again, without changing the code, I reran it for the third time, and it received the same error on iteration 2800.

I am not sure what is causing the error as the only explanation in the error is that:
Dot indexing is not supported for variables of this type: ’ hyd_res = d.getComputedTimeSeries’.

I am unsure as to why I get this error, and I am unsure as to when MATLAB decides to display this error as it has never happened at the same iteration twice.

Any assistance would be appreciated.

Thanks
Ethan

Hi @EthanPillay,

Please, if you can send me an example to reproduce the behavior?
mariosmsk@gmail.com

Regards,
Marios

Hi @Mariosmsk

Thank you for your response. I have sent you an email.
Thank you

Kind regards
Ethan